Excel : Tout savoir sur les fonctions RECHERCHEH et RECHERCHEV

Excel : Tout savoir sur les fonctions RECHERCHEH et RECHERCHEV

Peu importe le domaine dans lequel vous décidez de vous orienter, des bases en Excel sont souvent une compétence demandée, si ce n’est exigée, par les recruteurs. En effet, pour faire face à la quantité considérable de données avec lesquelles les entreprises doivent traiter aujourd’hui, savoir maîtriser Excel pour les analyser est primordial.

Parmi les formules les plus sollicitées, on retrouve les fonctions RECHERCHEH et RECHERCHEV qui sont utilisées dans la plupart des domaines. Découvrez à quoi elles servent et comment les utiliser !

 

Lire plus : Excel : retour sur toutes les formules et fonctions à connaître !

 

La fonction RECHERCHEH sur Excel

La fonction RECHERCHEH fait partie des fonctions les plus utilisées en entreprise. Il est important de connaître son équivalent anglais (HLOOKUP) qui est préféré dans les sociétés anglo-saxonnes.

Mais concrètement, à quoi sert la fonction RECHERCHEH ? Cette fonction permet de lier deux tableaux qui présentent chacun certaines composantes identiques. A travers une recherche horizontale (d’où le H), la fonction retrouve dans les lignes d’un tableau la valeur cherchée.


Prenons un exemple concret. Vous disposez des informations ci-dessous :

rechercheh

En fonction du dossier recherché (A-2 ici), vous souhaitez remplir les informations « Ville » et « Points » du tableau bleu. Bien que l’exercice puisse paraître immédiat ici et ne nécessitant pas de fonction Excel, imaginez faire le même travail pour plus de 10 000 dossiers. Une fonction qui vous trouve le résultat automatiquement devient très pratique.

Dans notre cas, pour trouver la ville qui correspond au dossier A-2, il vous faudra renseigner la formule suivante dans la cellule B11 :

=RECHERCHEH(B7;B1:K3;2;FAUX)

 

Expliquons cela :

  • La cellule B7 correspond à la valeur associée à la ville recherchée 
  • La matrice B1:K3 correspond au tableau de recherche dans lequel se trouve les valeurs dont vous avez besoin (le tableau en haut de la feuille où se trouve les informations)
  • 2 indique la ligne sur laquelle la fonction pourra trouver l’information recherchée (la ligne des villes par conséquent).
  • « FAUX » indique que vous ne souhaitez pas de valeur approximative. Si aucune ville n’était associée au dossier A-2, la cellule B11 affichera une formule d’erreur. A l’inverse, si vous aviez choisi « VRAI », la cellule aurait pu afficher le nom de la ville à côté, telle que Londres par exemple.

En inscrivant cette formule dans la cellule B11, cette dernière affichera Lyon.

 

De même pour la cellule C11, la formule

=RECHERCHEH(B7;B1:K3;3;FAUX)  affichera la valeur 35’471

 

Vous l’aurez compris, la formule générale de la fonction RECHERCHEH est la suivante

=RECHERCHEH(valeur associée ; matrice de recherche ; n° de la ligne où se trouve la valeur recherchée ; [VRAI] ou [FAUX] valeur approximative)

 

La fonction RECHERCHEV sur Excel

La fonction RECHERCHEV travaille de la même façon que la fonction RECHERCHEH. La seule différence est que la recherche s’effectue en colonne et non pas en ligne (recherche verticale pour V). Prenons là aussi un exemple.

recherchev

Vous cherchez à trouver la ville associée au dossier A-3 et la renseigner dans la cellule E6. Cette fois-ci, la recherche s’effectue par colonne. Il faudra donc renseigner la formule suivante dans la cellule E6 :

=RECHERCHEV(E2;A2:C11;2;FAUX)

 

De la même façon que pour la fonction RECHERCHEH, analysons chaque composante :

  • E2 renvoie au dossier auquel il faut associer la ville recherchée
  • A2:C11 correspond à la matrice de recherche
  • 2 fait référence au numéro de la colonne dans le tableau de recherche dans laquelle se situent les villes
  • FAUX signifie que l’on ne souhaite pas voir apparaître de valeur approximative

Précisons que la valeur 2 pour le numéro de colonne est uniquement valable dans la matrice de recherche. Si cette dernière commençait à la colonne D, il faudrait toujours renseigner la valeur 2 dans la formule, et non le numéro de la colonne vis-à-vis de l’ensemble de la feuille de calcul.

 

La formule générale de recherche verticale est (VLOOKUP) est donc la suivante :

=RECHERCHEV(valeur associée ; matrice de recherche ; numéro de colonne où se trouve l’information associée ; [FAUX] ou [VRAI] valeur approximative)

 

Bonus : découvrez la fonction RECHERCHEX sur Excel

La formule RECHERCHEX tend à remplacer la formule RECHERCHEV. En effet, l’inconvénient de cette dernière est qu’elle ne peut que rechercher les valeurs dans la première colonne de la matrice. Concrètement dans l’exemple précédent, si on avait inversé les colonnes « Dossier » et « Ville », la fonction RECHERCHEV n’aurait pas pu afficher de résultat et aurait renvoyé un message d’erreur.

Par conséquent, nous vous présentons en bonus la fonction RECHERCHEX, plus utile et plus facilement maniable. 

recherchex

Comme vous pouvez le voir, dans cet exemple, la valeur recherchée est le numéro de dossier associé à la ville de Genève. Dans la cellule E6, il faudra donc renseigner :

=RECHERCHEX(E2;B2:B11;A2:A11)

 

Expliquons cette fonction. Dans un premier temps, on remarque que seuls 3 arguments sont nécessaires pour cette formule, ce qui simplifie son écriture.

  • E2 correspond à la valeur associée au dossier recherché
  • B2:B11 correspond à la colonne dans laquelle se trouve cette valeur (la ville)
  • A2:A11 correspond à la colonne dans laquelle se trouve la valeur recherchée (le numéro de dossier)

 

Dans le cas de la recherche des points, la formule à renseigner dans la cellule F6 sera

=RECHERCHEX(E2;B2:B11;C2:C11)

De la même façon, il suffit d’indiquer les colonnes dans lesquelles effectuer les recherches. La formule générale de la fonction RECHERCHEX est donc :

=RECHERCHEX(valeur associée ; colonne dans laquelle se trouve cette valeur ; colonne dans laquelle se trouve la valeur cherchée)

 

En maîtrisant ces trois formules excel, vous disposez de premières bases très demandées en entreprise. Le plus important est maintenant de vous entraîner sur des bases de données aléatoires pour vérifier votre compréhension du mécanisme et développer des automatismes !

 

Lire plus : TOEIC, TOEFL, IELTS : comparatifs et explications

Rédactrice en chef de Planète Grandes Ecoles et étudiante en école, j'ai à coeur d'aider les étudiants à mettre toutes les chances de leur côté pour réussir !